Feeds:
Posts
Comentários

Archive for novembro \29\UTC 2010

Olá pessoal, depois de um tempo afastado, estou de volta!

Bom, o negócio é simples e rápido para variar… Quem de vocês nunca montou uma planilha e depois de prontinha, viu que a planilha ficou com muitas colunas e poucas linhas, tornando a leitura desagradável? Ex:

Exemplo - Muitas Colunas

Que tal invertermos os dados, colocando as linhas nas colunas e vice-versa sem perder os dados de lugar?
Faça o seguinte:
– Selecione todos os dados, para isso ficar fácil, basta clicar em qualquer célula preenchida e pressione CTRL + *;
– Pressione CTRL + C para copiar;
– Agora, clique com o botão direito do mouse no local onde irá colar a informação, e escolha Colar Especial;

Colar Especial

Na janela do colar especial, marque a caixa Transpor.

Colar Especial - Transpor

Lembre-se que para isso funcionar corretamente, você não deve colar sobre dados já existentes.

O seu resultado será esse:

Após transpor

Agora exclua as linhas excedentes, basta selecioná-las, e pressione CTRL + -.

Este é nosso resultado final:

Transpor - Final

Bem pessoal, mais um post. Chegamos aos 400 visitantes, mas, quero mais… Indiquem , convidem, divulguem!!!

Forte abraço e até a próxima!

Anúncios

Read Full Post »

Olá pessoal!

Vou voltar às funções básicas. Vou falar sobre uma função muito simples: a função Média. Ela permite recuperar a média de todos os valores de um (ou vários) intervalo(s).

Observe a planilha abaixo:

Função Média

Você deseja calcular a média mensal, como você procede?

É muito simples: você vai usar a função Média com a seguinte sintaxe na célula B5:

=Média(B2:B4)

Depois, basta selecionar a célula onde você encontrou o resultado e arraste pela alça de preenchimento (aquela cruz preta no canto inferior esquerdo da célula) até completar todos os meses.

Observação importante: Caso você tire uma média de um conjunto de células vazias, você encontrará como resultado DIV/O! Esta mensagem corresponde ao erro Divisão por Zero, que, como você sabe não é possível. Em breve colocarei uma dica bem legal para que isso não ocorra mais.

Nosso resultado final:

Função Média - Parte 2

Você pode melhorar a exibição do resultado, selecionando todas as médias, clicando na aba Início, grupo Número, e depois clicando em Diminuir casas decimais, até o nível de precisão que você desejar.

Função Média - parte 3

Isso resultará em uma exibição mais amigável:

Função Média - parte 4

 

Mole, mole! Agora continue divulgando e  visitando o blog frequentemente, ok?

Forte abraço!

Read Full Post »

Hallo!!!

Bem pessoal, agora que mesclei, não tem jeito… Vamos seguir com mais dicas avançadas: vou criar com vocês um gráfico condicional.

O que é um gráfico condicional? É um gráfico que muda de cor de acordo com um critério que você especificar. Por exemplo, você tem 3 estágios em uma linha de produção: Produção Baixa, Produção Esperada e Super Produção. Você gostaria de colocar estes estágios em três cores diferentes em um gráfico de colunas, com apenas 1 coluna e não três como normalmente seria…

Nosso problema é esse:

Gráfico condicional

Segue a planilha para você acompanhar comigo: Exemplo – Gráfico Condicional

Planilha salva? Vamos lá:

Crie três colunas onde vocês irão separar os valores: Produção Baixa, Produção Esperada e Super Produção. Você já sabe qual o critério de cada uma, então, precisamos dividir os valores de produção em suas colunas correspondentes:

Gráfico Condicional - Parte 2

Para Produção Baixa vamos fazer a seguinte função: =SE(B5<100000;B5;0), onde o valor de B5 aparecerá na coluna caso ele seja menor que 100.000 senão aparecerá 0.

Para Produção Esperada vamos fazer a seguinte função: =SE(E(B5>=100000;B5<=400000);B5;0), onde o valor de B5 aparecerá na coluna caso ele seja maior ou igual a 100.000 E menor ou igual a 400.000 senão aparecerá 0.

Para Super Produção vamos fazer a seguinte função: =SE(B5>400000;B5;0), onde o valor de B5 aparecerá na coluna caso ele seja maior que 400.000 senão aparecerá 0.

Não esqueça de arrastar as fórmulas para baixo!

Você terá o seguinte resultado:

Gráfico Condicional - Parte 3

Agora vamos montar o gráfico! Bem, no post Criando um gráfico rápido mostrei como vocês poderiam criar gráficos em um estalar de dedos.

A dica a seguir serve apenas para Office 2007 e 2010, galera mais velhinha, mande-me um e-mail que darei um apoio. Clique em uma área vazia da planilha e pressione ALT + F1, você terá um gráfico em branco.

Gráfico condicional - parte 4

Com o gráfico vazio inserido, vamos brincar um pouco! Selecione desde Super Produção até o último valor de sua coluna, copie e cole dentro do gráfico. Isso mesmo! Vai, tenta!

Agora clique na coluna azul que apareceu e lá no topo localize Ferramentas de Gráfico, Formatar.

Ferramentas de Gráfico, Formatar

Localize o botão Preenchimento da Forma e escolha a cor Verde, você pode também no grupo Estilos da Forma escolher um modelo verde pronto pré-configurado.

Seu gráfico ficará assim:

Gráfico Condicional

Agora repita o processo de copiar e colar para as outras duas colunas. Não esqueça de personalizar, ok? Lembre-se Produção Baixa em Vermelho, Produção Esperada em Azul e Super Produção em Verde.

Teremos este resultado ao final desta etapa:

Gráfico condicional - Quase Ok

Agora falta pouco, vamos aos ajustes finais:

Primeiro, iremos alterar os números referentes aos meses para o nome dos meses:

Clique no gráfico, vá em Ferramentas de Gráfico, Design e clique no botão Selecionar Dados. Em Rótulos do Eixo Horizontal (categorias) você deve clicar no botão Editar e depois selecione os meses das células A5 até A16 pressione Ok e depois Ok novamente e pronto, você terá este resultado:

Agora falta pouco para nosso Gráfico Condicional

Vamos aos “finalmentes”, clique com o botão direito sobre qualquer coluna deste gráfico e escolha Formatar Série de Dados… Na janela que se abre, simplesmente faça os seguintes ajustes:

Sobreposição de Séries: 100% – Isso fará com que as colunas fiquem uma sobre a outra, dando a impressão da troca de cor.

Largura do Espaçamento: Cerca de 20% – Isso fará com que as colunas fiquem mais largas dando um efeito muito interessante.

Este é nosso resultado final:

Gráfico Condicional 3 condições - Completo

Agora, experimente alterar o valor da produção em qualquer um dos meses para ver as colunas “mudando” de cor, e impressionando muita gente.

Malandramente, coloque o gráfico posicionado exatamente sobre a área onde você dividiu a informação. Ninguém precisa saber que tem um segredo ali atrás não é?

Solução - Gráfico Condicional

Lembro que com esta técnica, você pode criar gráficos condicionais com o número de cores que quiser. Tudo dependerá de quantas colunas de condições você criará.

Esta foi excelente, ou você esperava mais? Bem pessoal, comente, entre em contato e estarei pronto para postar mais e mais segredos por aqui. Ok? Abraços!

Auf Wiedersehen!

Read Full Post »

Olá Pessoal!

Vou começar a mesclar as coisas por aqui. Não posso apenas dar dicas muito básicas para vocês, desta vez, falarei para o pessoal mais avançado.

Quem aí já teve a necessidade de fazer um PROCV com 2 critérios ou mais? Vou mostrar um exemplo do que quero dizer:

2 Condições

Muitos ensinariam aqui que você deve criar uma coluna extra, concatenar as duas ou mais chaves desejadas para realizar o PROCV. Vou fazer diferente e tenho certeza que vocês vão adorar:

Primeiro, crie uma área onde você vai informar os critérios:

Área de critérios

Agora você precisa criar uma função que analise os critérios e a nossa tabelinha. Vamos lá?

Vamos trabalhar com duas funções que quando se juntam, vira uma festa: ÍNDICE E CORRESP. Na célula F4 digite =ÍNDICE(B2:B9;CORRESP(F2&F3;A2:A9&C2:C9;0)) e ao final pressione CRTL + SHIFT + ENTER para transformar esta função em uma matricial.

Índice e Corresp

Depois do CRTL + SHIFT + ENTER ficará assim:

Índice e Corresp 2

Vamos aos detalhes: A função ÍNDICE permite localizar um valor em uma matriz a partir de sua posição de linha e coluna. A matriz é de B2 até B9, você não sabe a linha onde a informação está, portanto, você precisa de algum recurso que permite localizar a posição do item ou no nosso caso itens que você pesquisa. Usaremos então CORRESP que vai pesquisar o conteúdo de F2 concatenado com F3, na matriz A2 até A9 concatenado com C2 até C9 com resultado exato (por isso o zero no final da função). Como não me interessa a coluna desejada, ignoro esta opção na minha função ÍNDICE. Pressiono CTRL + SHIFT + ENTER para gerar uma função matricial e pronto. Você acaba de encontrar o resultado da conctanação de dois critérios, sem usar PROCV.

Por essa você não esperava não é? Espero poder ajudar vocês em breve, mais e mais, comentem, divulguem, entrem em contato, pois este blog é para vocês.

Forte abraço! Auf Wiedersehen!

Read Full Post »

Olá Pessoal, vou começar a abordar sobre as funções do Excel. A primeira que vou falar é uma função muito simples: a função SOMA. Ela simplesmente resultará no somatório de tudo que você colocar como parâmetros. Você pode praticar com a planilha que coloquei disponível para download no post Criando um gráfico rápido .

Exemplo:

Calculando total

Você deseja calcular o total

Exemplo 1: Se eu desejar calcular o total de todos os meses, calculo da seguinte forma:

=SOMA(B2:G4)

Onde B2 é a célula inicial e G4 é a célula final.

Total Geral

Calculando o Total Geral - Observe a barra de fórmulas

Exemplo 2: Se eu quisesse apenas o mês de janeiro ficaria:

=SOMA(B2:B4)

Calculando o total de Janeiro

Calculando o total de Janeiro – Observe a barra de fórmulas


Exemplo 3: Mas, e se eu quisesse os meses de janeiro, março e maio, como faria? Neste caso, você deve informar para o Excel quais intervalos você deseja fazer o seu somatório, ficando assim:

=SOMA(B2:B4;D2:D4;F2:F4)

Calculando em intervalos não sequênciais

Calculando em intervalos não sequênciais


Muito tranquilo, não? Bom esta foi fácil, mas a partir de agora, sempre vou colocar uma função nova para você colocar no seu vocabulário de funções no Excel. Sigam divulgando, hein? Forte abraço e até a próxima!!!

Read Full Post »